Ruby related dependency issues on m1

I have encountered that while building jekyll on the m1 processor, that the native extensions for ffi which is a dependency for jekyll, rails and a few other frameworks, won’t run on the ARM based processor. It was built on an x86.

I have receved the following error:

# lots of extra lines...
types.rb:69:in `find_type': unable to resolve type 'size_t' (TypeError)


To solve this issue run this with your project specific version:

$ gem install ffi -- --disable-system-libffi